Simacan Connect Updaters - TomTom HDFlow Updater
Incident Report for Simacan B.V.
Resolved
This incident has been resolved.
Posted about 2 years ago. Oct 21, 2016 - 18:45 CEST
Investigating
auto-tsq.tomtom.com: unknown error
Posted about 2 years ago. Oct 21, 2016 - 18:22 CEST