Simacan Connect Updaters - NDW traveltime updater
Incident Report for Simacan B.V.
Resolved
This incident has been resolved.
Posted over 1 year ago. Oct 18, 2016 - 21:49 CEST
Investigating
Fout bij het ophalen van de NDW realtime data traveltime
Posted over 1 year ago. Oct 18, 2016 - 19:51 CEST