Simacan Connect Updaters - TomTom HDFlow Updater
Incident Report for Simacan B.V.
Resolved
This incident has been resolved.
Posted almost 2 years ago. Sep 27, 2016 - 13:45 CEST
Investigating
auto-tsq.tomtom.com:80 failed to respond
Posted almost 2 years ago. Sep 27, 2016 - 13:45 CEST