Simacan Connect Updaters - TomTom HDFlow Updater
Incident Report for Simacan B.V.
Resolved
This incident has been resolved.
Posted 5 months ago. Sep 18, 2017 - 15:32 CEST
Investigating
Posted 5 months ago. Sep 18, 2017 - 14:38 CEST