Simacan Connect Updaters - TomTom HDFlow Updater
Incident Report for Simacan B.V.
Resolved
This incident has been resolved.
Posted over 1 year ago. Nov 22, 2016 - 18:04 CET
Investigating
Connect to auto-tsq.tomtom.com:80 [auto-tsq.tomtom.com/185.5.121.141] failed: Connect timed out
Posted over 1 year ago. Nov 22, 2016 - 18:03 CET